.
Cerrar Ventana

Algunas cookies de este sitio son esenciales, y el sitio no funcionará como se espera sin ellas. Estas cookies se establecen en el momento de enviar un formulario, inicie sesión o interactuar con el sitio realizando una acción que va más allá de hacer clic en un simple enlace.


Leer Más

Solicitar soporte AQUÍ
Hosting Gratis, Hosting P2H y de pago, más información AQUÍ o AQUÍ    (Ver PLANES).
Solicitar Hosting Gratis AQUÍ .
Para que se habrán los enlaces de descarga pulsar el  Botón Gracias.

Resuelto Que paso con mi sitio web



07-23-2022, 03:26 AM #1
0
Hoy ingrese a mi sitio web y apareció este error

Fatal error: Uncaught Error: Call to undefined function mysqli_connect() in /home/u684539996/domains/litechan.com/public_html/inc/ext/functions.php:7 Stack trace: #0 /home/u684539996/domains/litechan.com/public_html/header.php(67): include() #1 /home/u684539996/domains/litechan.com/public_html/index.php(15): include('/home/u68453999...') #2 {main} thrown in /home/u684539996/domains/litechan.com/public_html/inc/ext/functions.php on line 7


No entiendo por que aparece esto si no hice ninguna modificación

(Última modificación: 07-24-2022, 03:07 PM por Tronlar. Razón: Añadir prefijo )
07-23-2022, 06:44 AM #2
1
Mejor respuesta del mensaje RE: Que paso con mi sitio webHola, yo veo ahora tu web bien.
Ese error no aparece solo, habrán hecho cambios en tu servidor, qué versión de PHP estás usando?

07-23-2022, 01:43 PM #3
0
(07-23-2022, 06:44 AM)Tronlar escribió: Debes agradecer para ver el contenido...Hola, yo veo ahora tu web bien.
Ese error no aparece solo, habrán hecho cambios en tu servidor, qué versión de PHP estás usando?

Php 7.4 estaba utilizando y luego con el error que aparecía cambie a 7.3 y dejo de aparecer el error

07-23-2022, 07:12 PM #4
0
(07-23-2022, 01:43 PM)Record404 escribió: Debes agradecer para ver el contenido...
(07-23-2022, 06:44 AM)Tronlar escribió: Debes agradecer para ver el contenido...Hola, yo veo ahora tu web bien.
Ese error no aparece solo, habrán hecho cambios en tu servidor, qué versión de PHP estás usando?

Php 7.4 estaba utilizando y luego con el error que aparecía cambie a 7.3 y dejo de aparecer el error

Te debería de funcionar en 7.4.
Mira si tienes en el archivo inc/ext/functions.php esto así
$db_link mysqli_connect($db['hostname'], $db['username'], $db['password'], $db['database']); 

eso hasta la versión de php8 debería de funcionar

07-24-2022, 02:42 PM #5
1
Mejor respuesta del mensaje RE: Que paso con mi sitio web
(07-23-2022, 07:12 PM)Tronlar escribió: Debes agradecer para ver el contenido...
(07-23-2022, 01:43 PM)Record404 escribió: Debes agradecer para ver el contenido...
(07-23-2022, 06:44 AM)Tronlar escribió: Debes agradecer para ver el contenido...Hola, yo veo ahora tu web bien.
Ese error no aparece solo, habrán hecho cambios en tu servidor, qué versión de PHP estás usando?

Php 7.4 estaba utilizando y luego con el error que aparecía cambie a 7.3 y dejo de aparecer el error

Te debería de funcionar en 7.4.
Mira si tienes en el archivo inc/ext/functions.php esto así
$db_link mysqli_connect($db['hostname'], $db['username'], $db['password'], $db['database']); 

eso hasta la versión de php8 debería de funcionar

Es un error de hostinger. No se que tipo de cambios an echo en su servidor, xq también mi otro script fue afectado

07-24-2022, 03:05 PM #6
1
Mejor respuesta del mensaje RE: Que paso con mi sitio web
(07-24-2022, 02:42 PM)Record404 escribió: Debes agradecer para ver el contenido...
(07-23-2022, 07:12 PM)Tronlar escribió: Debes agradecer para ver el contenido...
(07-23-2022, 01:43 PM)Record404 escribió: Debes agradecer para ver el contenido...
(07-23-2022, 06:44 AM)Tronlar escribió: Debes agradecer para ver el contenido...Hola, yo veo ahora tu web bien.
Ese error no aparece solo, habrán hecho cambios en tu servidor, qué versión de PHP estás usando?

Php 7.4 estaba utilizando y luego con el error que aparecía cambie a 7.3 y dejo de aparecer el error

Te debería de funcionar en 7.4.
Mira si tienes en el archivo inc/ext/functions.php esto así
 
$db_link mysqli_connect($db['hostname'], $db['username'], $db['password'], $db['database']); 

eso hasta la versión de php8 debería de funcionar

Es un error de hostinger. No se que tipo de cambios an echo en su servidor, xq también mi otro script fue afectado

Ok, gracias por dejar la solución, cualquier duda o lo que sea vuelves abrir otro tema.

(Última modificación: 07-24-2022, 03:06 PM por Tronlar.)



Compartir en:

Salto de foro:



Usuarios navegando en este tema:
1 invitado(s)