¡Bienvenido! ¿Aún no estás registrado?, deberás registrarte antes de poder usar el Chat, Comentar y Descargar en el Foro. Usa un email válido para la activación.
Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5

NOTICIAS Actualizaciones - SL3 y PHPost24 [31.03.24]
#1

10
Mejor respuesta del mensaje Actualizaciones - SL3 y PHPost24 [31.03.24]Hola a todos!

Lamento no estar dando actualizaciones últimamente, ya que me encuentro "tratando de mejorar mis habilidades", ya he realizado mejoras a Syntaxis Lite y PHPost, he mejorado los plugins que había diseñado para el funcionamiento del script. 
Además estoy realizando pequeños proyectos para hacer e integrar a los script y que a ustedes les pueda gustar y servir, por ahora los que hice, si son inútiles, que no se usaría.

Próximamente subiré los cambios!
Ya están los cambios, ambos en la rama "dev"

NOTA: 31.03.24 : PHPost
 - Se creó nueva rama 'main', esta versión es un poco más "estable".
 - Se repararon algunos conflictos
 - No usar las rama "master" y "dev"

NOTA: 26.03.24 : PHPost
 - Se cambio la ruta del repositorio Debes agradecer para ver el contenido...

NOTA: 10.03.24 : PHPost
 -
 
Estaré haciendo cambios a PHPost, por el momento no recomiendo su uso... (ya que tendrá errores)
 - Combinaré las ramas para que no se confundan, ni se compliquen.
 - Como empecé a usar Node.js y Astro, me dio ideas que quiero implementar para el futuro. Ejemplos:
   - Creación de componentes para poder pasarle parámetros y crear un objeto, cards, botones, etc...
   - Como se ordenan los archivos y como se escribe el código


NOTA: 10.03.24 : SL3 (syntaxis lite 3)
 -
 
Por el momento no tendrá cambios, más de lo mencionado antes ↓.

Debes agradecer para ver el contenido...: [Modo privado - inaccesible]
 - Pasa a ser v3 porque el cambio ya no es compatible con v2.
 - Mucho más estructurado.
 - Mucho más limpio.
 - Se eliminó la configuración JSON, ya se almacenará en la base de datos.
 - Nuevo plugins para añadir fuentes de google
 - Actualización completa del plugins function.hook.php
 - Actualización completa del plugins function.jsdelivr.php 
 - Actualización completa del plugins function.metadatos.php antes era function.meta.php

Debes agradecer para ver el contenido...:

 - Mucho más estructurado.
 - Mucho más limpio.
 - Actualización completa del plugins function.jsdelivr.php 
 - Actualización completa del plugins function.phpost.php es parecido a function.hook.php, pero mejor (lo termine hoy 02.03.24)
 - Optimizador de imágenes mejorado y reestructurado desde cero (Aún no estará disponible para su uso, pero funciona) 

En Syntaxis Lite v3 y PHPost
El plugin function.jsdelivr.php funcionará siempre y cuando exista la carpeta 'jsdelivr' con los plugins/complementos necesarios.
En la carpeta existirán los archivos .txt de los plugins/complementos que se pueden usar la CDN de jsdelivr, ejemplo:

Archivo: bootstrap.txt
Contenido:
 
​​​​​​​name: bootstrap
page: all
js: dist/js/bootstrap.bundle.min.js
css: dist/css/bootstrap.min.css
version: 5.3.2
on: false

El plugin lo que hará es buscar el archivo que se pase por el parámetro de esta forma:
 
{jsdelivr type="css" files=['bootstrap','pace','croppr']}

Se menciona el type ya que puede ser que solo tenga el css o el js, o en este caso ambos, esa línea dará como resultado
 
<link rel="stylesheet" href="Registrate o inicia tu sesión para ver este contenido" />

lo mismo se hace con los archivos locales del theme.

Se que algunos plugins como el de google fonts parecen inútiles, pero sirve para añadir una o varias, en este caso están limitadas y son:
Bebas Neue, Comfortaa, Lato, Montserrat, Open Sans, Oswald, Poppins, Proza Libre, Raleway, Roboto, Work Sans.

Por ahora esto todo...
Responder
#2

2
Gracias Miguel por seguir mejorando el Script sigue asi
Responder
#3

0
gracias hno pero la verdad no puedo realizar la instalacion en localhost nose porque despuesde realizar los pasos de lainstalacion me tira este error 
Fatal error: Uncaught Error: Call to undefined function imagecreatefromstring() in C:\xampp\htdocs\inc\class\c.jsondb.php:49 Stack trace: #0 C:\xampp\htdocs\inc\class\c.jsondb.php(125): tsJson->filePut('C:\\xampp\\htdocs...', 'Registrate o inicia tu sesión para ver este contenido', Array) #1 C:\xampp\htdocs\inc\class\c.jsondb.php(184): tsJson->generateImage('unplashjXd2FSvc...', 'C:\\xampp\\htdocs...', Object(stdClass)) #2 C:\xampp\htdocs\inc\ext\ajustes.php(84): tsJson->getAddInfo() #3 C:\xampp\htdocs\header.php(126): include('C:\\xampp\\htdocs...') #4 C:\xampp\htdocs\index.php(16): require_once('C:\\xampp\\htdocs...') #5 {main} thrown in C:\xampp\htdocs\inc\class\c.jsondb.php on line 49
Responder
#4

1
(03-03-2024, 02:30 PM)nakcho escribió: Debes agradecer para ver el contenido...gracias hno pero la verdad no puedo realizar la instalacion en localhost nose porque despuesde realizar los pasos de lainstalacion me tira este error 
Fatal error: Uncaught Error: Call to undefined function imagecreatefromstring() in C:\xampp\htdocs\inc\class\c.jsondb.php:49 Stack trace: #0 C:\xampp\htdocs\inc\class\c.jsondb.php(125): tsJson->filePut('C:\\xampp\\htdocs...', '', Array) #1 C:\xampp\htdocs\inc\class\c.jsondb.php(184): tsJson->generateImage('unplashjXd2FSvc...', 'C:\\xampp\\htdocs...', Object(stdClass)) #2 C:\xampp\htdocs\inc\ext\ajustes.php(84): tsJson->getAddInfo() #3 C:\xampp\htdocs\header.php(126): include('C:\\xampp\\htdocs...') #4 C:\xampp\htdocs\index.php(16): require_once('C:\\xampp\\htdocs...') #5 {main} thrown in C:\xampp\htdocs\inc\class\c.jsondb.php on line 49

Hola, voy a quitar ese archivo, pero de todas formas tienes que tener la librería GD de php activada para que funcione, ya que si no tendrás ese problema...

Coloca esto en el archivo index.php
var_dump(gd_info());
die; 

Y así verificas si esta activo o no, si esta activo, verás algo así
array(15) { ["GD Version"]=> string(26) "bundled (2.1.0 compatible)" ["FreeType Support"]=> bool(true) ["FreeType Linkage"]=> string(13) "with freetype" ["GIF Read Support"]=> bool(true) ["GIF Create Support"]=> bool(true) ["JPEG Support"]=> bool(true) ["PNG Support"]=> bool(true) ["WBMP Support"]=> bool(true) ["XPM Support"]=> bool(true) ["XBM Support"]=> bool(true) ["WebP Support"]=> bool(true) ["BMP Support"]=> bool(true) ["AVIF Support"]=> bool(true) ["TGA Read Support"]=> bool(true) ["JIS-mapped Japanese Font Support"]=> bool(false) }

Acá de dejó un "tutorial" de como activar dicha librería
Debes agradecer para ver el contenido...
Responder
#5

0
buen proyecto, de seguro lo usare Phpost actualizado.
Responder


Compartir en:

Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)